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Введение: 

В данном пособии рассматривается процесс создания плагина (графической 

оболочки) для автоматизации задачи прокатки металлического листа в SIMULIA 

Abaqus. Графическая оболочка - это окно, позволяющее в интерактивном режиме 

собрать задачу для анализа и запустить расчёт (Рис. 1). 

 

Рис. 1 Окно пользовательского интерфейса для задачи прокатки. 

Пособие состоит из двух частей. В части 1 пошагово собирается задача 

прокатки стального листа (В настоящее время отсутствует детальное описание 

математической модели). Часть 2 посвящена параметризации задачи и созданию 

графической оболочки в программном комплексе SIMULIA Abaqus.   

 Графическая оболочка создаётся для программного кода, написанного на 

языке Python 2х, выполняющего сборку модели и запуск её на расчёт. 

Самый простой способ создать Python код для Plug-in использовать Macro 

Manager. Макрос записывает действия пользователя в виде Python команд и 

воспроизводит их при запуске. Как было отмечено выше, плагин создаётся на 

основе Python функции. В программировании функции – это средства, 

позволяющие группировать наборы инструкций так, что в программе они могут 
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запускаться неоднократно. Функции могут вычислять некоторый результат и 

позволять указывать входные параметры, отличающиеся по своим значениям от 

вызова к вызову. 

Предложенный способ не единственно возможный, но с точки зрения автора, 

один из самых простых. 

Для успешного выполнения заданий пособия знание синтаксиса языка Python 

является желательным, но не обязательным условием. Моменты, связанные с 

языком программирования, целенаправленно опущены, а все правки текста 

программного кода сопровождены скриншотами.  

Ориентировочное время выполнения задания – 4 часа. 

 

С любыми пожеланиями и замечаниями, обращайтесь по адресу: 

simulia_support@tesis.com.ru.  
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Часть 1 (Создание модели) 
 

В данном разделе будет собрана модель прокатки стального листа. Для упрощения 

дальнейшей работы с материалами пособия, рекомендуем придерживаться 

последовательности выполнения предложенных действий. На выходе мы получим 

python скрипт – макрос, с которым будем работать в части 2 настоящего пособия.  
 

Активируем запись макроса для задачи: 

File -> Macro Manager… -> Create -> Введите имя макроса Steel_rolling и 

директорию Home -> Continue… -> Появится окно Record Macro 

идентифицирующие, что Abaqus CAE начал записывать совершаемые вами 

команды. Не закрывайте окно Record Macro до специального указания. (Рис. 2) 

Создадим модель стальной плиты (Рис. 3 слева): 

Parts -> Create…-> Name: plate, Modeling Space: 2D Planar, Type: Deformable, 

Base Feature: Shell, Approximate size: 0.5. -> Continue… -> Начертите 

прямоугольник с высотой равной 0.02 (м) и длиной 0,092 (м), для этого введите 

координаты левого угла (-0.092 0.0), правого (0.0 0.02) -> Done. Такое определение 

важно для дальнейшего анализа. 

Создадим модель прокатного ролика (Рис. 3 справа): 

Parts -> Create… -> Name: Roller, Modeling Space: 2D Planar, Type: Analytical 

rigid, Base Feature: Wire, Approximate size: 2.0 -> Continue… -> Начертите четверть 

дуги окружности радиусом 0,17 (м) -> Done. 

Tools -> Reference Point -> разместите её в центре созданной окружности. 

Создадим материал (Рис. 4): 

Materials -> Name: Steel; Material Behaviors: Mechanical – Elasticity – Elastic, 

Data: Young’s Modulus = 1.5e11 (Па), Poisson’s Ratio = 0.3, General – Density = 7850 

(кг/м3), Mechanical – Plasticity – Plastic Data: Yield Stress = [1.6872e8, 2.1933e8, 

2.7202e8, 3.0853e8, 3.3737e8, 3.6158e8, 3.8265e8, 4.0142e8, 4.1842e8, 4.3401e8, 

4.4845e8] (Па), Plastic Strain = [0.0, 0.1, 0.2, 0.3, 0.4, 0.5, 0.6, 0.7, 0.8, 0.9, 1.0].  
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Рис. 2 Создание макроса. 

 

Рис. 3 Создание геометрии стальной плиты и прокатного ролика. 

 

Рис. 4 Определение свойств материала плиты. 
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Создадим сечение и присвоим его стальной плите (Рис. 5): 

Sections -> Name: Steel, Category: Solid, Type: Homogeneous -> Continue… -> 

Activate Plane stress/strain thickness: 1 -> OK. 

Parts -> plate -> Section Assignments -> Выберете деталь -> Done -> Section: 

Steel -> OK.  

Соберём модель (Рис. 6): 

Assembly -> Instances -> Parts: Roller, plate -> OK. Переместите правый 

нижний угол плиты в начало координат. В начальной конфигурации ролик касается 

плиты точкой отстоящей от одного из его концов на 20% его длины. Создадим эту 

точку. Tools -> Datum -> Type: Point, Method: Enter parameter -> Выделите грань 

катка -> Normalized edge parameter (0.2) -> Подтвердить действия. Сопрягите 

верхний правый угол пластины и созданную точку на поверхности катка. 

Создадим удобные для дальнейшей работы сеты: 

Assembly -> Sets = [bottom (нижняя грань плиты), plate (вся плита целиком), 

refPt (Опорная точка катка)]. 

И поверхности: 

Assembly -> Surfaces = [roller (грань катка со стороны плиты), topPlate 

(верхняя и правая грани плиты)]. 

Задание свойств анализа (Рис. 7): 

Steps -> Name: Single Pass Rolling, Procedure type: General Dynamic, Explicit -

> Continue… -> Time period: 0.1 -> Во вкладке Mass scaling выберете Use scaling 

definitions below -> Create -> Application, Region: Set = plate, Type: Scale by factor = 

1600 -> OK -> убедитесь в том, что окно Edit Step выглядит, как на рисунке 8 -> 

OK. 

В результате анализа кроме нагружено-деформируемого состояния плиты 

интересно получить силу и момент действующую на ось ролика (Рис. 9).  
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Рис. 5 Задание свойств сечений. 

 

Рис. 6 Создание сборки модели. 

 

Рис. 7 Создание шага анализа. 
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Рис. 8 Задание свойств анализа. 

History Output Requests -> Step: Single Pass Rolling -> Domain: Set = refPt, 

Interval = 100 -> Forces/Reactions -> RT, RM. (Рис. 9 слева) 

Активируем адаптацию сетки (Рис. 9 справа): 

Other -> ALE Adaptive Mesh Domain -> Manager -> Edit -> Use the ALE adaptive 

mesh domain below, Region -> указатель мыши (выбрать из графического окна) -> 

Sets (внизу графического окна) -> plate -> Continue… -> Remeshing sweeps per 

increment = 3. -> OK -> Dismiss. 

Определим контакт (Рис. 10): 

Interaction Properties -> Name: Friction, Type: Contact -> Continue… -> 

Mechanical -> Tangential Behavior -> Friction formulation: Penalty -> Friction Coeff = 

0.4. 

Interactions -> Name: Friction; Surface-to-surface contact (Explicit) -> Continue… 

-> Surfaces…-> roller-> Continue… -> Surface ->  topPlate -> Continue… -> OK. 

Граничные условия (Рис. 11): 

Каток вращается с угловой скоростью 2π рад/с. Скорость пластины в 

начальный момент времени равна 2π*0.17 = 1.01587 м/с. 

BCs -> Name: bottom, Step: Initial, Displacement/Rotation -> Continue… -> 

bottom -> Continue… -> U2 = 0. 
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Рис. 9 Выбор вычисляемых переменных и активация адаптации сетки. 

 

Рис. 10 Определение контакта. 

 

Рис. 11 Задание граничных условий. 
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BCs -> Name: fixRoll, Step: Initial, Displacement/Rotation -> Continue… -> refPt 

-> Continue… -> U1 = U2 = 0. 

BCs -> Name: rotateRoll, Step: Single Pass Rolling, Velocity/Angular velocity -> 

Continue… -> refPt -> Continue… -> VR3 = 2*π. 

Зададим начальную скорость плиты (Рис. 12): 

Predefined Fields -> Name: initVel; Step: Initial; Category: Mechanical; Types for 

Selected Step: Velocity -> Continue… -> Sets -> Выберете set: plate -> Continue… -> 

V1: 1.01587 -> OK. 

Сетка (Рис. 13): 

Для данной задачи будут использоваться элементы CPE4R из библиотеки 

Abaqus/Explicit. 

Plate (в дереве модели) -> Mesh (Empty) -> Mesh -> Element Type -> Element 

Library: Explicit; Family: Plane Strain -> OK -> Seed -> Part -> Approximate global size: 

0.002 -> OK -> Mesh -> Part -> Yes. 

Part: Roller (см. Рис !) -> Seed Part -> Approximate global size: 0.02 -> OK. 

Определение анализа (Рис. 14): 

Jobs -> Name: rolling -> Continue… -> OK -> Job Manager -> Submit. 

В окне Record Macro нажмите на кнопку Stop Recording. 
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Рис. 12 Задание начальных условий. 

 

Рис. 13 Создание конечно-элементной сетки. 

 

Рис. 14 Расчётная сетка и создание процедуры анализа.   
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Часть 2. Python. Создание диалогового окна. 

В данном разделе рассмотрен процесс создания графической оболочки на основе 

python скрипта, записанного в первой части настоящего пособия. Выполняя 

инструкции, особое внимание стоит уделять форматированию вашего кода, чтобы 

избежать дальнейших ошибок. Всегда сверяйте ваш код, с приведенными 

примерами программного кода. 

 

После того, как был записан файл макроса, можно переходить к созданию 

диалогового окна с помощью инструмента RSG Dialog Builder встроенного в ПК 

SIMULIA Abaqus. 

Данный процесс условно делится на две части: 

1. Подготовка python функции. 

2. Создание графического интерфейса пользователя. 

Перейдите в Home directory. Обычно это C:\Users\PC_name. Чтобы не 

повредить исходный файл abaqusMacros.py содержащий информацию о 

проделанных действиях в части 1, сделайте его копию с именем rolling.py, 

переместите его в вашу рабочую директорию, после чего откройте файл с помощью 

редактора кода встроенного в Abaqus (File –> Abaqus PDE… -> File -> Open -> 

rolling.py), или бесплатным текстовым редактором Notepad++.  

Инструкция “def Steel_rolling(): “ в языке Python (Рис. 15) создает объект 

функции и связывает его с именем Steel_rolling. В строке заголовка в круглых 

скобках после имени перечисляются подающиеся ей на вход аргументы или 

параметры. Пустые скобки означают, что функция не принимает на вход никаких 

значений, а сама функция, в нашем случае, выполняет инструкции, прописанные в 

теле функции, соответствующие построению и запуску на расчёт задачи проката 

стальной пластины. 

В данном разделе будут внесены изменения в тело функции. Код будет 

модифицирован так, чтобы функции на вход подавались основные 

параметры/объекты задачи и на основе данной функции создать графический 

интерфейс plug-in в Abaqus CAE (Рис. 16).  
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Рис. 15 Окно Abaqus PDE. Определение функции Steel_rolling. 

 

Рис. 16 Окно пользовательского интерфейса для задачи прокатки. 

  

Изменение Python скрипта: 

Откройте файл rolling.py с помощью Abaqus PDE… (File –> Abaqus PDE-> 

File -> Open -> rolling.py). Для того чтобы  

Для корректной работы функции необходимо подгрузить библиотеки для 

работы со средой Abaqus. Добавьте три строчки в начало открытого файла 

rolling.py, подгружающие классы Abaqus (Рис. 17). 

mailto:info@tesis.com.ru
http://www.tesis.com.ru/


 

Современные технологии - в промышленность 

Программное обеспечение 
Инженерный консалтинг 
Вычислительная техника 
Измерительное оборудование 

 

 

ООО «ТЕСИС», 127083, Россия, Москва, ул.Юннатов 18,  офис 705     
Тел/факс: +7 (495) 612-4422, 612-4262    E-mail: info@tesis.com.ru www.tesis.com.ru 
 

from abaqus import * 

from abaqusConstants import * 

import __main__ 

 Начало файла должно выглядеть, как показано на Рис. _ . 

 

Рис. 17 Заголовок файла rolling.py 

На данном шаге нам необходимо провести параметризацию задачи, на вход 

функция должна получать значения переменных указанных в таблице ниже. 

Каждая переменная должна быть ассоциирована с её объектным именем внутри 

функции. 

Переменные Keyword 
Длина (Length) L 

Толщина (Height1) H 

Толщина после прокатки (Height2) h 

Радиус валика (Radius) R 

Модель материала (Material) NameMaterial 

Размер конечного элемента (Element size) seedsize 

Угловая скорость валика (Angular 

velocity) 
Omega 

Коэффициент трения (Friction coefficient) mu 

Время анализа (Analysis time) an_time 

Таблица 1. Соответствие переменных и имен объектов. 

Чтобы упростить последующее редактирование файла создайте несколько 

пустых строчек таким образом, чтобы 39 строчка на рис.18  совпадала с 39 строчкой 

в вашем файле. Если все действия, описанные в Части 1 были проделаны в строгом 

соответствии с данным пособием, то номера строк должны совпадать. Совпадение 

строк не является обязательным условием работоспособности кода, а делается для 

удобства дальнейшей навигации по файлу. 
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Для начала сопоставим длине, толщине стальной пластины объекты с 

именами L и H соответственно. Для этого замените строку 6 (Рис. 18) на 

 Steel_rolling(L, H): 

а 39 строка должна включать данные объекты  

s.rectangle(point1=(-L, 0.0), point2=(0.0, H)).  

 

Рис. 18 Добавление переменных L, H в функцию. 

Объект с именем R соответствует радиусу валика, добавьте его в список 

переменных, передаваемых в функцию (Рис. 18), а команда на создание дуги 

окружности должна выглядеть следующим образом:  

s1.RadialDimension(curve=g[2], textPoint=(-0.264792740345001,  

        -0.16046154499054), radius=R) 

 

 

Рис. 18 Добавление переменной R в функцию. 

 Создадим три разных материала стали, на данном этапе различающиеся 

только названиями. Для этого, функция будет принимать на вход объект 

NameMaterial, который необходимо добавить в список переменных. В зависимости 

от имени переменной «Steel1»,  «Steel2» или  «Steel3», свойства материалов могут 
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различаться. Присвоение свойств в зависимости от имени материала реализуется с 

помощью конструкции if:. За создание материала и присвоение ему механических 

свойств отвечает участок кода, показанный на рисунке 20. Модифицируйте тело 

функции так, чтобы создание материала происходило так, как показано на рисунке 

21. Определение материала должно выглядеть следующим образом: 

if NameMaterial == 'Steel1': 

        mdb.models['Model-1'].Material(name=NameMaterial) 

        mdb.models['Model-1'].materials[NameMaterial].Elastic(table=((150000000000.0, 0.3), 

                                                                )) 

        mdb.models['Model-1'].materials[NameMaterial].Density(table=((7850.0, ), )) 

        mdb.models['Model-1'].materials[NameMaterial].Plastic(table=((168720000.0, 0.0), ( 

            219330000.0, 0.1), (272020000.0, 0.2), (308530000.0, 0.3), ( 

            337370000.0, 0.4), (361580000.0, 0.5), (382650000.0, 0.6), ( 

            401420000.0, 0.7), (418420000.0, 0.8), (434010000.0, 0.9), ( 

            448450000.0, 1.0))) 

 if NameMaterial == 'Steel2': 

        mdb.models['Model-1'].Material(name=NameMaterial) 

        mdb.models['Model-1'].materials[NameMaterial].Elastic(table=((150000000000.0, 0.3), 

                                                                )) 

        mdb.models['Model-1'].materials[NameMaterial].Density(table=((7850.0, ), )) 

        mdb.models['Model-1'].materials[NameMaterial].Plastic(table=((168720000.0, 0.0), ( 

            219330000.0, 0.1), (272020000.0, 0.2), (308530000.0, 0.3), ( 

            337370000.0, 0.4), (361580000.0, 0.5), (382650000.0, 0.6), ( 

            401420000.0, 0.7), (418420000.0, 0.8), (434010000.0, 0.9), ( 

            448450000.0, 1.0))) 

if NameMaterial == 'Steel3': 

        mdb.models['Model-1'].Material(name=NameMaterial) 

        mdb.models['Model-1'].materials[NameMaterial].Elastic(table=((150000000000.0, 0.3), 

                                                                )) 

        mdb.models['Model-1'].materials[NameMaterial].Density(table=((7850.0, ), )) 

        mdb.models['Model-1'].materials[NameMaterial].Plastic(table=((168720000.0, 0.0), ( 

            219330000.0, 0.1), (272020000.0, 0.2), (308530000.0, 0.3), ( 

            337370000.0, 0.4), (361580000.0, 0.5), (382650000.0, 0.6), ( 

            401420000.0, 0.7), (418420000.0, 0.8), (434010000.0, 0.9), ( 

            448450000.0, 1.0))) 

mdb.models['Model-1'].HomogeneousSolidSection(name='Steel', material=NameMaterial,  

           thickness=1.0) 

 

Очень внимательно отнеситесь к отступам. Проверьте, что перед конструкцией if, 

нет пробелов, а внутренние инструкции имеют отступ равный 1 табуляции (4 

пробела).  
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Рис. 20 Участок кода, отвечающий за определение свойств материала. 

 

Рис. 21 Модифицированный участок кода, отвечающий за определения материала. 
 Для того чтобы модель была собрана верно, необходимо определить 

взаимное положение стальной плиты относительно ролика. Правый нижний угол 

плиты находится в начале координат (0, 0). Для того чтобы получить нужную 

толщину детали на выходе равную h, центр ролика должен иметь координаты 

((√𝑅2 − (ℎ + 𝑅 − 𝐻)2 + 𝜀),  (ℎ + 𝑅)), как показано на рисунке 22. Параметр 𝜀 = 10−5 

нужен для того, чтобы гарантировать, что поверхность валика не пересекает 

верхней поверхности стальной плиты. 
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Рис. 22 Схематичное изображение взаимного расположения элементов. 

 Передайте в функцию объект h и измените строку, выделенную на рис. 23  

a1.translate(instanceList=('Roller-1', ), vector=((sqrt(R**2-(h+R-H)**2)+0.00001), (h+R), 0.0)) 

 

Рис. 23 Измененный участок кода, отвечающий за взаимное положение элементов. 

 Передайте в функцию объект mu, отвечающий за коэффициент трения и 

измените строку, выделенную на рисунке 24. 

mdb.models['Model-1'].interactionProperties['Friction'].TangentialBehavior( 

        formulation=PENALTY, directionality=ISOTROPIC, slipRateDependency=OFF,  

        pressureDependency=OFF, temperatureDependency=OFF, dependencies=0,  

        table=((mu, ), ), shearStressLimit=None, maximumElasticSlip=FRACTION,  

        fraction=0.005, elasticSlipStiffness=None)  
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Рис. 24 Определение коэффициента трения. 

Возможно, для некоторых конфигураций задачи потребуется увеличить время 

анализа, для этого передайте в функцию объект an_time и выделенном участке кода 

(Рис. 25) после previous=’Initial’, вставьте строку timePeriod=an_time. 

 

Рис. 25 Определение времени анализа. 

 Угловая скорость вращения валика – объект с именем Omega, который 

необходимо передать функции Steel_rolling на вход (Рис. 26). Измените значения 

переменных vr3 на  Omega (vr3=Omega), отвечающую за скорость вала, и velocity1 

на Omega*R (velocity1=Omega*R), отвечающую за скорость стальной плиты в 

начальный момент времени. 
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Рис. 26 Определение угловой скорости валика и начальной скорости плиты. 

 Значение переменной seedsize отвечает за размер конечных элементов, на 

которые разбивается стальная пластина. Передайте объект seedsize в функцию. И 

измените значение параметра size, в выделенном на рисунке 27 участке кода на 

size=seedsize. 

 

Рис. 27 Определение размера конечных элементов. 

  

Проверьте отступы в файле и сохраните файл (File -> Save). 
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Создание графического окна в RSG Dialog Builder. 

Plu-ins-> Abaqus -> RSG Dialog Builder.  

Во вкладке GUI в графе Dialog Box Title введите Rolling. С помощью 

инструмента Horizontal Frame создайте горизонтальную группу объектов. Выделив 

Horizontal Frame дважды создайте вертикальную группу объектов, используя 

инструмент Vertical Frame, так как показано на рис. 28. 

 

Рис. 28 Интерфейс RSG Dialog Builder. 

Выделив первый Vertical Frame, создайте Group Box, с помощью 

одноименного инструмента. В графе Title введите Geometry (Рис. 29). 

Выделив объект Geometry создайте четыре текстовых поля для ввода 

используя инструмент Text Field.  

Отредактируйте первое текстовое поле. Text: Length (m): ; Type: Float; 

keyword: L ; Default: 0.092. 

Все изменения, производимые в Really Simple GUI Dialog Builder можно 

отслеживать непосредственно в небольшом окошке, которое появляется 

автоматически (Рис. 29).  
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Второе текстовое окно отвечает за ввод толщины стального листа (Рис. 30). 

Text: Height1 (m): ; Type: Float; keyword: H ; Default: 0.02. 

Третье -  за ввод толщины стального листа после прокатки. Text: Height2 (m): 

; Type: Float; keyword: h ; Default: 0.015. 

Четвертое -  за радиус прокатного ролика. Text: Radius (m): ; Type: Float; 

keyword: R ; Default: 0.17. 

Добавьте разделитель с помощью инструмента Separator. 

И создайте Combo Box (Рис. 31). Type: Standard; Text: Material: ; Keyword: 

NameMaterial; Default: Steel1; Выбрав Item измените Text: Steel1, второй item -> 

Text: Steel2, третий -> Text: Steel3. 

 Добавим Group Box, Mesh. Выделите Первый Vertical Frame и нажмите на 

Group Box. Назовите его Mesh. Используя “стрелки” перенесите его ниже Group 

Box, Geometry (Рис. 32). Создайте текстовое поле и отформатируйте его. Text: 

Element size (m): ; Type: Float; keyword: seedsize ; Default: 0.002. 

 Создайте Group Box с именем Experiment setup, переместите его под модуль 

Mesh. Внутри данного модуля создайте два текстовых поля и отформатируйте их. 

Первое: Text: Angular velocity (rad/s): ; Type: Float; keyword: Omega ; Default: 

6.28319. Второе: Text: Friction coefficient: ; Type: Float; keyword: mu ; Default: 

0.4. 

Создайте Group Box с именем Analysis setup, переместите его под модуль 

Experiment setup (Рис. 29). Создайте одно текстовое поле.  Text: Analysis time: ; 

Type: Float; keyword: an_time ; Default: 0.1. 
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Рис. 29 Интерфейс RSG Dialog Builder. 
 

  

Рис. 30 Создание модуля Geometry. Рис. 31 Создание модуля Material. 

 Добавим поясняющую картинку к данной задаче. Выберете второй Vertical 

Frame и создайте Icon с помощью одноименного инструмента. В появившемся окне 

укажите полный путь к изображению. В результате диалоговое окно будет 

выглядеть, как показано на рисунке 34. 

 Объединим созданную нами python функцию с графической оболочкой.  

Перед этим в рабочей директории создайте копию файла rolling.py, чтобы избежать 

его потери. Перейдите во вкладку Kernel (Рис. 35). В окне Module: выберете 

инструмент Load a kernel module file from the File Selection dialog и выберете 

функцию rolling.py. В графе Function: выберете созданную нами функцию 

Steel_rolling. 
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 Перейдите обратно во вкладку GUI и сохраните плагин с помощью 

инструмента Save your dialog box as a plug-in. 

 В качетсве Directory name и Menu button name введите Steel_rolling  

(Рис. 36 слева). Выберете место для сохранения плагина  в модуле Location. В 

нашем случае это Home directory и нажмите ОК. После чего, Abaqus покажет место, 

куда были сохранены данные созданного плагина и попросит перезапустить 

программу, для того чтобы воспользоваться созданным плагином. 

 Перезапустите Abaqus. Запустите созданный плагин. Plug-ins -> Steel_rolling 

(Рис. 36 справа). Подтвердите ввод параметров нажатием клавиши ОК и убедитесь 

в том, что модель была создана и отправлена на расчёт. При возникновении 

ошибки, Abaqus укажет на номер строки в файле кода, которую необходимо 

исправить.  

 

 
 

Рис. 32 Создание модуля 

Mesh. 

Рис. 33 Создание модуля Analysis time. 
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Рис. 34 Окно созданного графического пользовательского интерфейса. 

 

Рис. 35 Вкладка Kernel. RSG Dialog Builder. 

 

Рис. 36 Сохранение плагина и его последующее использование. 
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Заключение: 

 В данном пособии рассмотрен процесс создания графического интерфейса 

пользователя в программном комплексе SIMULIA Abaqus. Данный подход 

является универсальным и позволяет создавать интерактивные оболочки для задач 

любой сложности. Для более глубокого понимания Python инструкций, 

рекомендуем обратиться к Abaqus Scripting User’s Guide. Использование Python в 

инженерных задачах может существенно сократить время анализа путём 

автоматизации рутинных операций,  уменьшить вероятность совершения ошибок 

пользователем и выполнять оптимизацию. 

 Python – свободный объектно-ориентированный язык программирования 

интегрированный в SIMULIA Abaqus. На официальном сайте  python.org можно 

найти исчерпывающее описание языка, документацию и примеры. Существует две 

версии языка Python 2.x и Python 3.х, Abaqus работает с версией 2. 
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